Drools need jpa 2.1 . Current hibernat version is 3

Hi For new drools 7.10.0 we need jap 2.1 . Do i need to upgrade hibernate 3 to above also to support jpa 2.1 or it won’t affect?

You will have to update, ideally to the version that is required/tested by drools. I think the first JPA 2.1 compatible implementation is Hibernate 4.3.