Cannot open index with Luke

I want to open indexed file with Luke , But I have this error log.

Cannot open index path D:\data\hch\entity.myEntity. Not a valid lucene index directory or corrupted?

I try with all Directory Implementation options, But I still have this error.

Os: windows 7
Hibernate search: 5.9.2.Final

Hibernate Search Config:

setProperty("hibernate.search.default.directory_provider", "filesystem");
setProperty("hibernate.search.default.indexBase", "/data/hch");
setProperty("hibernate.search.Rules.directory_provider", "filesystem");
setProperty("hibernate.search.jmx_enabled", "true");
setProperty("hibernate.search.generate_statistics", "true");

All I can tell you is that it should work with the default options of Luke. Maybe just enable “read-only”, and double-check you are selecting the right directory. I know the GUI used to be really disturbing; if I remember correctly you had to first select the parent directory, then the index directory, then click “OK”.

Luke version was incompatible with apache lucene version that used in my project. I tried with other Luke versions, the problem solved.

1 Like

I am using lucene 5.5.4 and luke v8.0.0
i am facing same issue. will you please suggest luke version for lucene 5.4.4
and also from where to download luke

Please try with versions under 6.
Link

Have you tried turning on read-only mode?