Latest stable Hibernate Search version: 5.11.7.Final

Note that this version:

  • requires Java 8
  • requires Hibernate ORM 5.4.0.Final or later
  • requires Apache Lucene 5.5.x
  • includes experimental Elasticsearch integration

For migration instructions from Hibernate Search version 5.10, please see:


For migration instructions from Hibernate Search version 4.x, please see: