Is it java 8 still supported in Hibernate 5.4.2?

#1

Hello,

Hibernate 5.4.2 defines a dependency with jaxb library.

But I have noticed that, due to this change, some of the required dependencies like:

have classes which are compiled with JDK9 (major version 53). Taking this account can you ensure that JDK8 is still fully supported?

Thank you in advance.

0 Likes

#2

Hello,

please forget about this. I’ve noticed that the only .class compiled with JDK9 is the module-info.class, so there is not any issue at all.

Regards.

1 Like

#3

Yes i guess…It is still supported.Though pls confirm from other sources too.

0 Likes

#4

Hi @Fred25

thanks for the response. Yes it is still supported, I wrongly thought that it could not be supported because I found a class compiled with JDK9 in those libraries. But it was just the module-info.class.

So this does not affect to the JDK8 support at all.

1 Like